[Win10] Singleplayer WC with unbearable lag

Discussion in 'Support' started by Augurex, Jan 7, 2019.

  1. Augurex

    Augurex Nobuild

    Hello, everyone, I've been interested in submitting a builder application, but since the website is being worked on for a while, some pages aren't loading, including the builder application page.

    Wanting to get a start on an initial build, I checked out singleplayer. Made a world, started clearing out land for a build, etc. Then this unbearable lag just started building and building until the program couldn't function. I quit out, came back on, checked WC Multiplayer (everything was fine), and went back to SP. Same issue after a couple of minutes. This time, before closing out, it said something like Java SE Binary Not Responding.

    I've:

    -closed out of WC and reopened.
    -uninstalled and reinstalled both MC and WC
    -updated my NVIDIA driver (!)
    -installed Java (lol, turns out I didn't have it)
    -restarted my computer
    -deleted Java cache after googling the aforementioned Java problem

    I'm still having the same problem. So far, I've started four different creative SP worlds, deleting each one after running into the problem.

    It's also funny, whenever I leave SP and return to the WC menu screen, then join WC multiplayer from there, it's like the lag has jumped over to that from the SP. But that issue is easily fixed by quitting and opening up again.

    Would like to be a builder, but it would suck if I got hindered by such a stupid problem. :( Or maybe I'm just an idiot and missing something glaringly obvious (always a possibility...)

    -Aug

    p.s.- tried to find launcher log, but I'm not sure where it is.
     
  2. Augurex

    Augurex Nobuild

    *ahem*

    It turns out I was just an idiot and missed something glaringly obvious.

    In fact, it was almost the first thing a couple people suggested to me. "Did you turn up your view distance?" I had said no, because I hadn't turned it up while in SP, but the settings it was on did carry over from MP.

    Anyway, turning down view distance to an acceptable 14+ seems to have done the trick. I am no longer having any issues. *knock on wood*
     
  3. geeberry

    geeberry Kingthlayer Admin

    nice - glad it got figured out!