Double click brushes

Kor_Bro

Playwright
Hey there!
These last couple of days, I've been trying to wrap my head around the bug with placing things twice with the schemebrush.
I heard from other builders this was a known issue that appeared whenever you stood too close to where you placed stuff. However, in my case it does so even when i'm far away. As in nowhere near the block i'm placing a schematic at. It was very frustrating, but luckily i could get around that issue, by binding /undo to a hotkey.
I later found however, when i was trying to do a bit of terraforming, that it wasn't only affecting my schemebrushes, but also my normal brushes. Which kind of messes with the terraforming job. A lot! I thought to myself that it must be my mouse not working properly, since i'm the only one experiencing this issue, including the far away double click. So, i went to google and found other people having the same issue, something related to windows 10, and so I sat down and tried to find a solution that eventually let me to breaking my mouse (Great job Kor). I then went out to get a new mouse.... - which seemed to have the same problem... and so i tried another.. same problem.
Eventually i tried keybinding my block placing key to my keyboard instead of my mouse, and found it doing the same thing.
Therefore i assume it has nothing to do with neither my keyboard or my mouse. and that the problem with double click other people on google was experiencing was a different problem.
I think this has something to do with the known bug already, related to the schemebrushes when placing too close to the targeted block.

Is this something someone else has been experiencing? and is it possible to find a solution for it?

What I know:
- I've only experienced it in westeroscraft.
- It only seem to affect my brushes. Nothing else.
- I can place blocks by hand just find and my wand seem to work just fine too, same with voxel.
- I'm certain that I only click once, and yet two clicks are registered.

I hope I/we can find a solution to this, as it makes terraforming awfully frustrating.

Kind regards.
Kor
 

CashBanks

Shadowbinder
Yep I’ve been having the same problem with both schem brushes and regular brushes, except I have found that backing up away from where i’m pasting does mitigate the problem.

Strange that it’s still happening to you even when you’re far away. Have you tried extending the /range of the brush to like 40 blocks and seeing if it’s still an issue?
 

Elduwin

Sorcerer
Hey, I don't know if it could help but:
- does it happen with voxel brushes too? or is it WE related?
- could you try with items like snowballs, eggs, or spawn eggs, because for me it doesn't do the double click, as you throw it. Maybe that's one way to get around the problem.
 

Kor_Bro

Playwright
So something weird just happened. I'm not quite sure what I did, but for some reason, it seems to have fixed the problem.
I opened up controls in-game, hoping I could find some WE related controls is could mess around with to fix it. In the "WorldEdit CUI 2 Forge Edition" section, there's an "Options" control not bound to any key. So I bound that to a key and opened up the options. It popped up with a few WE selection parameters, as well as a few tick boxes to activate or deactivate certain options. I didn't click on anything except the tick box named "Distance measurer" which was already activated, and so I deactivated it.
And for some reason that seemed to do the trick. I was now able to use schematic brushes and normal brushes, as they are supposed to work. Even, when I was super close.
To double check, I went back in order to activate it again. And once I did that, I was surprisingly still able to use my brushes normally. I then logged out to see if these changes were saved, and logging back in showed me they were.
I don't know why this should fix it, but for some reason, it did, even though I changed everything back to what it was before.
I'm still unsure of how this worked, but I don't think I did anything else.